Intermittent Communicator Issues
Incident Report for Nimvelo
Resolved
A permanent fix has now been implemented and the new version deployed. We welcome any feedback and/or reports of further issues.
Posted Jun 18, 2020 - 13:35 BST
Identified
The issue has been identified and a fix is being implemented. In the meantime, we have published a guide to working around the issue for anyone affected: https://kb.nimvelo.com/article/454-communicator-adi
Posted Jun 17, 2020 - 12:23 BST
Update
We are continuing to investigate this issue although we have been unable to reproduce the behaviour locally and have not received any new reports. In the meantime, if you are experiencing the same or similar issues with Communicator, please submit as much information as possible, including browser/version and any errors reported in the console, to support@nimvelo.com.
Posted Jun 16, 2020 - 16:09 BST
Investigating
We have received reports of intermittent issues making and receiving calls using the Communicator web-app. Calls are otherwise unaffected on other devices and this appears to be related to specific browsers/versions.

We are investigating and will provide an update shortly.
Posted Jun 16, 2020 - 12:54 BST
This incident affected: Nimvelo Phone (Apps).