Communicator issues
Incident Report for Nimvelo
Resolved
This incident has been resolved.
Posted Jan 04, 2021 - 11:29 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 04, 2021 - 11:00 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 04, 2021 - 10:49 GMT
Investigating
We have received reports of customer having trouble logging into Communicator and are investigating
Posted Jan 04, 2021 - 10:24 GMT
This incident affected: Nimvelo Phone (Voice / SMS).