Intermittent call and API issues
Incident Report for Nimvelo
Resolved
This incident has been resolved.
Posted May 20, 2020 - 11:08 BST
Identified
The issue has been identified and a fix is being implemented.
Posted May 20, 2020 - 10:56 BST
Investigating
We are currently investigating this issue.
Posted May 20, 2020 - 10:46 BST
This incident affected: Nimvelo Phone (Voice / SMS, API).